Neue Antwort schreiben 
 
Themabewertung:
  • 1 Bewertung(en) - 1 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
ext4 Berechtigungen deaktivieren
mrshadowtux
Unregistered

 
Beitrag #1
ext4 Berechtigungen deaktivieren
Moin,
folgende Situation: Ein Fileserver, auf dem alle alles dürfen sollen und jegliche Form von "Keine Berechtigung" nur vollkommen nervt. Auf dem Server ist eine NFS-Freigabe. In der /etc/exports steht
Code:
/data 10.23.0.0/16(rw,no_subtree_check)
also sollte das gesamte Netz ja Lese- und Schreibzugriff haben. Außerdem wurde schon chmod -R 777 /data ausgeführt.
Soweit die Theorie.

In der Praxis ist es so, dass die Berechtigungen spinnen, sobald man von einem verbundenen Client aus neue Verzeichnisse in der Freigabe anlegt und in diese neuen Verzeichnisse etwas reinkopieren/löschen will. Dann gibts "Keine Berechtigung"-Gezicke.
Nun meine Frage: Kann man ext4 nicht mit irgendeinem Parameter mounten, dass der ganze Rechteverwaltungsfoo deaktiviert ist? In diesem Falle ist jegliche Rechteverwaltung nur nervig und nicht zielführend.

Jemand Ideen?

Schöne Grüße vom Tux
31.01.2014 23:58
Diese Nachricht in einer Antwort zitieren
tk1908 Offline
Unixer

Beiträge: 7.147
Registriert seit: Apr 2009
Beitrag #2
RE: ext4 Berechtigungen deaktivieren
(31.01.2014 23:58)mrshadowtux schrieb:  Moin,
folgende Situation: Ein Fileserver, auf dem alle alles dürfen sollen und jegliche Form von "Keine Berechtigung" nur vollkommen nervt. Auf dem Server ist eine NFS-Freigabe. In der /etc/exports steht
Code:
/data 10.23.0.0/16(rw,no_subtree_check)
also sollte das gesamte Netz ja Lese- und Schreibzugriff haben. Außerdem wurde schon chmod -R 777 /data ausgeführt.
Soweit die Theorie.

In der Praxis ist es so, dass die Berechtigungen spinnen, sobald man von einem verbundenen Client aus neue Verzeichnisse in der Freigabe anlegt und in diese neuen Verzeichnisse etwas reinkopieren/löschen will. Dann gibts "Keine Berechtigung"-Gezicke.
Nun meine Frage: Kann man ext4 nicht mit irgendeinem Parameter mounten, dass der ganze Rechteverwaltungsfoo deaktiviert ist? In diesem Falle ist jegliche Rechteverwaltung nur nervig und nicht zielführend.

Jemand Ideen?

Schöne Grüße vom Tux

Blöde Frage, fußt die "Rechteverwaltung" von NFS net irgendwie auf der UID? Meine da mal was gelesen zu haben.

[Bild: Rz3JNLI.gif]
Meine Beiträge stehen unter der MIT-Lizenz:D

(09.04.2016 14:26)tk1908 schrieb:  externe HDD am Router? Klar ich tausch mein Auto gegen nen Tretroller mit Bremsklotz.
01.02.2014 00:01
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren
mrshadowtux
Unregistered

 
Beitrag #3
RE: ext4 Berechtigungen deaktivieren
Unter welchem Nutzernamen läuft das dann denn? Dem des zugreifenden Clients? Am liebsten würde ich den ganzen Rechtekram in dem Falle wie gesagt ganz weg haben. Falls es da auch für NFS passende Parameter gibt, wären die natürlich nicht verkehrt.
Danke schonmal!
01.02.2014 00:02
Diese Nachricht in einer Antwort zitieren
tk1908 Offline
Unixer

Beiträge: 7.147
Registriert seit: Apr 2009
Beitrag #4
RE: ext4 Berechtigungen deaktivieren
(01.02.2014 00:02)mrshadowtux schrieb:  Unter welchem Nutzernamen läuft das dann denn? Dem des zugreifenden Clients? Am liebsten würde ich den ganzen Rechtekram in dem Falle wie gesagt ganz weg haben. Falls es da auch für NFS passende Parameter gibt, wären die natürlich nicht verkehrt.
Danke schonmal!

Probiers mal mit "all_squash", damit werden die UIDs/GIDs auf nobody gemappt.

[Bild: Rz3JNLI.gif]
Meine Beiträge stehen unter der MIT-Lizenz:D

(09.04.2016 14:26)tk1908 schrieb:  externe HDD am Router? Klar ich tausch mein Auto gegen nen Tretroller mit Bremsklotz.
01.02.2014 00:10
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren
Alpha Offline
Oskar

Beiträge: 15.890
Registriert seit: Jan 2009
Beitrag #5
RE: ext4 Berechtigungen deaktivieren
Ist das evtl. NFSv4? Weil da sind die Mountpoints anders zu realisieren als bei v3..

Mark IV Style Motherfucker!
01.02.2014 00:22
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren
mrshadowtux
Unregistered

 
Beitrag #6
RE: ext4 Berechtigungen deaktivieren
(01.02.2014 00:10)tk1908 schrieb:  Probiers mal mit "all_squash", damit werden die UIDs/GIDs auf nobody gemappt.
Damit funzt es, vielen vielen Dank!

Schöne Grüße vom Tux
01.02.2014 00:30
Diese Nachricht in einer Antwort zitieren
tk1908 Offline
Unixer

Beiträge: 7.147
Registriert seit: Apr 2009
Beitrag #7
RE: ext4 Berechtigungen deaktivieren
(01.02.2014 00:30)mrshadowtux schrieb:  
(01.02.2014 00:10)tk1908 schrieb:  Probiers mal mit "all_squash", damit werden die UIDs/GIDs auf nobody gemappt.
Damit funzt es, vielen vielen Dank!

Schöne Grüße vom Tux

Gern geschehen. :)

[Bild: Rz3JNLI.gif]
Meine Beiträge stehen unter der MIT-Lizenz:D

(09.04.2016 14:26)tk1908 schrieb:  externe HDD am Router? Klar ich tausch mein Auto gegen nen Tretroller mit Bremsklotz.
01.02.2014 00:32
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren
tk1908 Offline
Unixer

Beiträge: 7.147
Registriert seit: Apr 2009
Beitrag #8
RE: ext4 Berechtigungen deaktivieren
Ich krall mir grade mal diesen Thread hier.

Ich hab aktuell das gleiche Problem. Gegeben ist n Synology DSM. Mein User hat die UID 1025 aufm NAS und die 1000 meinen Clients. Mounten und Lesen des Shares funktioniert einwandfrei, allerdings kann ich nichts in das Share schreiben.

Hat einer von euch ne Idee, wie ich das Mapping einstellen muss?

Irgendwer, der ne Synology DS besitzt?

[Bild: Rz3JNLI.gif]
Meine Beiträge stehen unter der MIT-Lizenz:D

(09.04.2016 14:26)tk1908 schrieb:  externe HDD am Router? Klar ich tausch mein Auto gegen nen Tretroller mit Bremsklotz.
17.01.2015 18:36
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren
mrshadowtux
Unregistered

 
Beitrag #9
RE: ext4 Berechtigungen deaktivieren
Systemsteuerung->Gemeinsame Ordner->Doppelklick auf Name des Ordners->NFS-Berechtigungen

Da könnte man was finden
17.01.2015 19:48
Diese Nachricht in einer Antwort zitieren
tk1908 Offline
Unixer

Beiträge: 7.147
Registriert seit: Apr 2009
Beitrag #10
RE: ext4 Berechtigungen deaktivieren
(17.01.2015 19:48)mrshadowtux schrieb:  Systemsteuerung->Gemeinsame Ordner->Doppelklick auf Name des Ordners->NFS-Berechtigungen

Da könnte man was finden


Die Einstellungen hab ich schon ausprobiert.

[Bild: Rz3JNLI.gif]
Meine Beiträge stehen unter der MIT-Lizenz:D

(09.04.2016 14:26)tk1908 schrieb:  externe HDD am Router? Klar ich tausch mein Auto gegen nen Tretroller mit Bremsklotz.
17.01.2015 19:54
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren
Neue Antwort schreiben 


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste